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Overview 

System Requirements 

1 Overview 

“ROS (Robot Operating System) is an open-source, meta-operating system for your robot. It 

provides the services you would expect from an operating system, including hardware abstraction, 

low-level device control, implementation of commonly-used functionality, message-passing 

between processes, and package management.” (http://wiki.ros.org/ROS/Introduction) 

The focus of ROS is on robotics but the field of application has become much wider. Especially for 

scientists and developers of Advanced Driver Assistance Systems the software framework became 

very interesting. 

IPG Automotive is currently developing an interface and workflow to allow the usage of ROS in 

combination with Car-/TruckMaker. The topics code building, message passing and synchronization 

as well as test automation and parameterization are touched and will be explained in this 

document. 

The functionality provided by ROS and the CarMaker Toolchain are quite wide, so there is not only 

one way to combine the two frameworks. This document describes an early proof-of-concept 

solution where the workflow of the ROS and CarMaker worlds are considered both. In the future 

there might be additional variations with tendency to the preferred workflow. 

This document is written for users that already have deeper knowledge with the CarMaker 

programming interface (see CarMaker Programmers Guide) and general ROS usage (see e.g. 

http://wiki.ros.org or http://wiki.ros.org/ROS/Tutorials) 

 

1.1 System Requirements 

General system requirements are linked to the requirements of CarMaker (see CarMaker 

ReleaseNotes) and ROS (see http://www.ros.org/). Table 1-1 shows the compatibility and existing 

examples for different operating systems and ROS Versions. 

 

Platform ROS ROS 2 

Linux 64bit 

Example HelloCM with ROS workspace 

 

Tested for 

 Kinetic Kame (Ubuntu 16.04) 

 Melodic Morenia  (Ubuntu 18.04) 

 Noetic Ninjemys (Ubuntu 20.04) 

Example HelloCM with ROS workspace 

 

Tested for 

 Dashing Diademata1  (Ubuntu 18.04) 

 Eloquent Elusor1  (Ubuntu 18.04) 

 Foxy Fitzroy (Ubuntu 20.04) 

 Galactic Geochelone (Ubuntu 20.04) 

Windows 
Currently no investigation on these platforms 

Xenomai 

Table 1-1: Compatibility for different operating systems and ROS versions 

                                            
1 Some minor changes in the Launch File hellocm.launch.py necessary. 

http://wiki.ros.org/ROS/Introduction
http://wiki.ros.org/ROS/Tutorials
http://www.ros.org/
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1.2 Concept 

ROS comes with a variety of functionality where the communication via topics within the same or 

across systems and the control of nodes via services and parameters are some of the most 

interesting components for modular systems exchanging data for complex control tasks. The 

CarMaker ROS Interface (CMRosIF) tries to support these functionalities as much as possible to 

allow a seamless software integration in different development states. Therefore a ROS Node has 

been implemented directly into the CarMaker executable (Figure 1). 

 

Figure 1: CarMaker ROS Interface and ROS Node Dependencies 

 

When talking about the CarMaker ROS Interface the functionality of two main modules described 

below are addressed. 

In order to keep the CarMaker functionalities over a wide range of application variants, the 

“CarMaker ROS Node” (CMNode) is not a typical ROS style standalone executable, but wrapped 

into a shared library dependent on several ROS libraries (generally ROS basic libraries and 

user defined libraries/packages e.g. with messages) and may have dependencies on CarMaker 

libraries (e.g. libcarmaker.a for access to the Vehicle struct). The C++ code for this shared library is 

editable by the user and can be dynamically loaded into a prepared CarMaker executable with the 

CarMaker C++ Interface Loader extension (might be provided as static or shared library). 

The CarMaker C++ Interface Loader extension provides an API to the user accessible C code 

modules and Infofile mechanism of CarMaker. The extension manages the CarMaker C++ Interface 

shared libraries and allows for basic parameterization via CarMaker Infofile. It provides functions for 

common CarMaker hook points (to be called in e.g. User.c or User.cpp). While these are 

predefined functions and some of them are optional it is also possible to create custom functions in 

the CarMaker C++ Interface (e.g. CarMaker ROS Node) and load these symbols with a general 

mechanism assigning them to function pointers and calling them at any point in the CarMaker cycle 

(after basic initialization has finished). 
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The CarMaker ROS Node can act as a clock server by publishing the /clock topic with the current 

simulation time to other ROS Nodes (http://wiki.ros.org/Clock). Therefore the /use_sim_time 

parameter needs to be set to “true” before other nodes are initialized (e.g. via launch file). Figure 2 

shows the rqt Node Graph for a simple Node configuration where cm_node publishes the /clock 

topic that is subscribed by all currently running nodes. 

 

 

Figure 2: ROS rqt Node Graph for the HelloCM Example 

 

CarMaker differs between the start of the CarMaker executable and a single simulation (running a 

TestRun). This allows to load the CarMaker ROS Node shared library at CarMaker startup or before  

the next simulation starts. The latter version is interesting when “restarting” the CarMaker ROS 

Node without a restart of the complete CarMaker executable (e.g. systems with complex 

initialization phase). Currently the shared library is loaded at CarMaker startup while the 

“dynamic start” of the CarMaker ROS Node is planned for the future. 

 

 

Figure 3: Overview – CarMaker GUI Extension 

 

Finally the CarMaker ROS Interface comes with a CarMaker GUI Extension providing some basic 

functionalities for working with the ROS environment like editing the CMRosIF parameter file 

(CarMaker Infofile) or starting default ROS programs via CarMaker GUI. More information see “4.2 

CarMaker GUI Extension”. 

http://wiki.ros.org/Clock
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General Information 

2 Quick Start 

This chapter gives a short instruction to run an example including the CarMaker ROS 

Interface, a ROS workspace with several packages and additional files for a specific 

CarMaker version. 

2.1 General Information 

 Several scripts are not CM default and experimental for fast ramp up of this example! 

 Current interface and build process is a prototype and will be improved in the future 

2.2 Installation and Preparation 

2.2.1 ROS 

 Follow the installation instructions for 

 ROS: http://wiki.ros.org/ROS/Installation 

 ROS 2: e.g. https://docs.ros.org/en/foxy/Installation/Linux-Install-Debians.html 

  e.g. https://docs.ros.org/en/foxy/Tutorials/Colcon-Tutorial.html#install-colcon 

 By default ROS installations are located under /opt/ros/ 

 For convenience you may set a symbolic link to your preferred ROS and ROS 2 distribution, so 

you won’t have to provide the distro to your ROS workspace each time before rebuilding, e.g.: 

1: cd /opt/ros 

2: sudo ln -sfn noetic ros1 

3: sudo ln -sfn foxy ros2 

 Check your ROS installations: 

ROS ROS 2 

roscore 

Open a new terminal and run 

source /opt/ros/ros1/setup.bash 

roscore 

Talker 

Open a second terminal and run 

source /opt/ros/ros1/setup.bash 

rosrun roscpp_tutorials talker 

Listener 

Open a third terminal and run 

source /opt/ros/ros1/setup.bash 

rosrun roscpp_tutorials listener 

Talker 

Open a new terminal and run 
source /opt/ros/ros2/setup.bash 

ros2 run examples_rclcpp_minimal_publisher 

publisher_member_function 

 
Subscriber 

Open a second terminal and run 
source /opt/ros/ros2/setup.bash 

ros2 run examples_rclcpp_minimal_subscriber 

subscriber_member_function 

 

http://wiki.ros.org/ROS/Installation
https://docs.ros.org/en/foxy/Installation/Linux-Install-Debians.html
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2.2.2 CarMaker and CMRosIF 

 Install CarMaker according to "InstallationGuide.pdf"  

 Configure your ~/.bashrc for easier use, e.g. add 

# Additional paths for CM 

addpath ()    { for d in "$@"; do PATH="$PATH:$d"; done; }  

addpath /opt/ipg/hil/linux/bin /opt/ipg/hil/linux/GUI /opt/ipg/hil/linux/GUI64 

addpath /opt/ipg/bin /opt/ipg/carmaker/linux64/bin /opt/ipg/carmaker/linux64/GUI 

 Please note that for older CarMaker versions (< 8.0) there is a special installation routine for 

Ubuntu! 

 Prepare your CarMaker/TruckMaker/MotorcycleMaker project directory to use the CarMaker 

ROS Interface 

 The CMRosIF needs an already existing project directory with an included source folder 

(src/, src_tm/ or src_mm/ folder with CM_Main.c, …) to build the CarMaker executable. If 

the source folder is missing please use “CM Main GUI -> File -> Project Folder -> Update 

Project…” with enabled component “Sources/Build Environment”. 

 It is recommended to version control (or backup) your existing project directory 

 Copy the files from the provided zip file to the corresponding folders in your project 

directory (e.g. by directly extracting inside the directory) 

 Update the source folder (e.g. src/, src_tm/ or src_mm/) 

 If your CarMaker project is newly created it is safe to apply the provided patch: 

cd <CMProjDir>/src_cmrosif 

./patch.sh ../<source folder> 

This will update your project’s User.c and Makefile located under <source folder> 

with the necessary modifications 

 Otherwise merge in the differences manually using your favorite merge tool (e.g. meld) 

<CMProjDir>/src_cmrosif/Makefile  <CMProjDir>/<source folder>/Makefile 

<CMProjDir>/src_cmrosif/User.c  <CMProjDir>/<source folder>/User.c 
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2.3 Build the Example 

Build ROS workspace (CarMaker ROS Node shared library, messages, external nodes) and the 

CarMaker executable: 

 For an initial build (or rebuild) of the ROS workspace it is recommended to build via CM 

Makefile, as it will automatically set the according CarMaker version and include paths in the 

CMake cache of the ROS workspace 

 Open a terminal and navigate to your CarMaker projects source directory 

 To build the CarMaker executable and the respective ROS workspace, run 

cd <CMProjDir>/<source directory> 

make cm-ros1 <or> make cm-ros2 

 Subsequent builds of the ROS workspaces can be done directly without the help of the CM 

Makefile using the ROS build tools 

cd <CMProjDir>/ros/ros_<1 or 2>ws 

catkin_make <or> colcon 

 If you also want to rebuild the workspace without the help of the CM Makefile or if you are 

sharing your workspace with other people you should define the expected CarMaker versions in 

the appropriate CMakeLists.txt and toggle the ability to set the CM version from outside. For 

e.g. CarMaker 9.1.1 you would set the following in  

<CMProjDir>/ros/ros1_ws/src/cmnode_hellocm/CMakeLists.txt and 

<CMProjDir>/ros/ros2_ws/src/cmnode_hellocm/CMakeLists.txt 

set(GET_CM_VERSION_FROM_CMD_LINE_OR_CACHE OFF) 

#... 

set(CARMAKER_VER 9.1.1) 

set(CARMAKER_NUMVER 90101) 

and for CarMaker versions < 8.0 also the variable CARMAKER_DIR to 

set(CARMAKER_DIR $ENV{IPGHOME}/hil/linux-${CARMAKER_VER}) 

2.4 Run the Example 

 Once everything is built you can start the ./CMStart.sh script in your project directory 

 This script gets initially generated by the CM Makefile and may be customized to your liking  

 It takes a single digit (e.g., 1 or 2) as an optional argument to source your ROS or ROS 2 

workspace before starting CarMaker 

 When no argument is provided, the ROS workspace that you have built first using the CM 

Makefile is chosen by default 

 CarMaker Main GUI with menu "Extras -> CMRosIF" should be visible 

 The starting order for roscore and nodes is important! 

 In this version the external node is started via launch file (roscore is started automatically) 

 Ensure the correct CarMaker executable has been selected via "CM Main GUI -> 

Application -> Configuration/Status" 

 "Folder"-Button : Choose bin/CarMaker.linux64 or src/CarMaker.linux64 which 

was built previously 
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 Depends on your workflow! Special search order is used (see "CM Main GUI -> Help -> 

User's Guide") e.g. you can also write "CarMaker.linux64" (first "bin/” in current project 

is checked, then Installation folder) 

 Ensure that the correct parameters are set in the CMRosIFParameters file: “CM Main GUI -> 

Extras -> CMRosIF -> Edit Parameters” 

 For ROS 2, at least Cfg.Args and Launch.Args have to be changed for the example to 

work 

 For more information have a look at cp. 4.3 Infofile Parameterization 

 Start external ROS Node and CarMaker Application via "CM Main GUI -> Extras -> 

CMRosIF -> Launch & Start Application" 

 If the external node was just started via “Launch” you can start the CarMaker 

executable via " CM Main GUI -> Application -> Start & Connect" 

 If you are using a ROS 2 Distribution older than Foxy, you will need to rename the 

fields namespace, name and executable inside the launch file 

ros/ros2_ws/src/hellocm/launch/hellocm.launch.py to node_namespace, 

node_name and node_executable respectably! 

 The CM Main GUI should show that CarMaker is running in idle state 

 Check log messages from executable via "CM Main GUI -> Simulation -> Session Log" 

 The Linux terminal should show the log messages for the external node 

 Open a TestRun e.g. Examples/Powertrain/PowertrainControl/AdaptiveCruiseControl 

via "CM Main GUI -> File -> Open..." 

 Push the "Start"-Button in CM Main GUI and check the output in the Session Log and terminal 
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2.5 Check the Communication with ROS Tools 

 Rqt can be started conveniently via "CM Main GUI -> Extras -> CMRosIF -> Start rqt" 

 Alternatively open a new terminal, source your ROS workspace and start rqt 

 ROS:    source <CMProjDir>/ros/ros1_ws/devel/setup.bash && rqt 

 ROS 2: source <CMProjDir>/ros/ros2_ws/install/setup.bash && rqt 

 Rqt lets you use several provided plugins, like 

 running Nodes via "Plugins -> Introspection -> Process Monitor" 

 node interaction via "Plugins -> Introspection -> Node Graph" 

 logging via "Plugins -> Logging -> Console" 

 and much more … 

2.6 Parameter Manipulation 

ROS parameters might be manipulated in several ways: 

 Using ROS tools 

ROS ROS 2 

rosparam in new terminal 

cd <CMProjDir> 

source ros/ros1_ws/devel/setup.bash 

rosparam list 

rosparam get /hellocm/cycletime 

rosparam set /hellocm/cycletime 50 

ros2 param in new terminal 

cd <CMProjDir> 

source ros/ros2_ws/install/setup.bash 

ros2 param list 

ros2 param get /hellocm cycletime 

ros2 param set /hellocm cycletime 50 

 

 Using CarMaker (e.g. for test automation) 

 Currently no direct support 

 Tcl’s exec command may be used with ScriptControl 
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3 Examples 

3.1 HelloCM 

 

 

Figure 4: ROS rqt Node Graph for the HelloCM Example 

 

 Simple example for demonstration of communication 

 The current example can be used with or without hard synchronization between the CarMaker 

ROS Node an the external ROS Node 

 The synchronization can be enabled/disabled in the CMRosIF Parameter file via “CM Main 

GUI -> Extras -> CMRosIF -> Edit Parameters” and the Parameter Node.Sync.Mode 

 CarMaker can act as a clock server and provide simulation time to other ROS nodes 

 Related ROS packages with source code, launch files, etc. are located in 

<CMProjDir>/ros/<workspace>/src 

3.1.1 Topic Based Synchronization 

The general synchronization method is described in chapter “4.7 Process Synchronization”. 

The HelloCM example allows an activation of the synchronization using the parameter 

Node.Sync.Mode (see chapter “Infofile Parameterization”) and provides the User Accessible 

Quantity CMRosIF.HelloCM.SynthDelay to create an artificial delay in the external ROS Node. 
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Figure 5: User Accessible Quantity to test synchronization 

By default the synchronization is off and results in a behavior shown in Figure 6. The CarMaker 

ROS Node acts as a clock server and publishes simulation time to the ROS network. The external 

node reacts on the current ROS time by publishing a message with its currently known simulation 

time (2). This message is received by the CarMaker ROS Node at simulation time (1) with a non-

constant delay. The third transmission at 30s was additionally delayed with an artificial delay of one 

second. 

 

Figure 6: Simulation without synchronization 
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The same simulation was started with Node.Sync.Mode = 1 (Figure 7). Here all messages arrive 

deterministically after the external Node has been triggered (the Log output has a constant delay of 

1ms). 

 

 

Figure 7: Simulation with topic based synchronization 
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4 Documentation 

4.1 Folder/File Overview 

The paths below are relative to the CarMaker Project Directory and describe the structure and 

contents after the integration of the CMRosIF files. Files and folders in italic will be available after 

building. The structure can be adapted for different use cases (references in files will have to be 

updated). 

CM_CMRosIF_HelloCM                   CM_CMRosIF_HelloCM/ros/ros1_ws          CM_CMRosIF_HelloCM/ros/ros2_ws           
 ├── bin                              ├── build                               ├── build                           
 │   └── CarMaker.linux64             ├── devel                               ├── install                         
 ├── Data                             ├── src                                 ├── src                              
 │   ├── Config                       │   ├── cmnode_hellocm                  │   ├── cmnode_hellocm                   
 │   │   ├── CMRosIFParameters        │   │   ├── src                         │   │   ├── src                          
 │   │   └── ...                      │   │   │   ├── cmnode_hellocm.cpp      │   │   │   ├── cmnode_hellocm.cpp       
 │   ├── Script                       │   │   │   └── cmnode_hellocm.h        │   │   │   └── cmnode_hellocm.hpp       
 │   │   ├── CMRosIF_UserUtils.tcl    │   │   ├── CMakeLists.txt              │   │   ├── CMakeLists.txt               
 │   │   └── ...                      │   │   └── package.xml                 │   │   └── package.xml                  
 │   └── ...                          │   ├── cmrosutils                      │   ├── cmrosutils                       
 ├── doc                              │   │   ├── include                     │   │   ├── include                      
 │   ├── CMJobScheduler               │   │   │   └── cmrosutils              │   │   │   └── cmrosutils               
 │   ├── CMJobScheduler.html          │   │   │       ├── cmcppif.h           │   │   │       ├── cmcppif.h            
 │   └── CMRosIF_UsersGuide.pdf       │   │   │       ├── CMJob.h             │   │   │       ├── CMJob.h              
 ├── GUI                              │   │   │       ├── cmjob_publisher.h   │   │   │       ├── cmjob_publisher.hpp  
 │   └── CMExt-CMRosIF.mod            │   │   │       ├── cmjob_subscriber.h  │   │   │       ├── cmjob_subscriber.hpp 
 ├── include                          │   │   │       └── cmrosif.h           │   │   │       └── cmrosif.hpp          
 │   ├── cmcppif.h                    │   │   ├── lib                         │   │   ├── lib                          
 │   └── cmcppifloader.h              │   │   │   └── libCMJob.a              │   │   │   └── libCMJob.a               
 ├── lib                              │   │   ├── src                         │   │   ├── src                          
 │   └── libcmcppifloader-linux64.so  │   │   │   └── cmrosif.cpp             │   │   │   └── cmrosif.cpp              
 ├── ros                              │   │   ├── srv                         │   │   ├── srv                          
 │   ├── ros1_ws                      │   │   │   └── CMRemoteControl.srv     │   │   │   └── CMRemoteControl.srv      
 │   └── ros2_ws                      │   │   ├── CMakeLists.txt              │   │   ├── CMakeLists.txt               
 ├── src                              │   │   └── package.xml                 │   │   └── package.xml                  
 │   ├── CarMaker.linux64             │   ├── hellocm                         │   ├── hellocm                          
 │   ├── CM_Main.c                    │   │   ├── launch                      │   │   ├── launch                       
 │   ├── CM_Vehicle.c                 │   │   │   └── hellocm.launch          │   │   │   ├── hellocm.launch.py        
 │   ├── IO.c                         │   │   ├── src                         │   │   │   └── hellocm.launch.xml       
 │   ├── IOVec.h                      │   │   │   └── hellocm.cpp             │   │   ├── src                          
 │   ├── Makefile                     │   │   ├── CMakeLists.txt              │   │   │   └── hellocm.cpp              
 │   ├── User.c                       │   │   └── package.xml                 │   │   ├── CMakeLists.txt               
 │   └── User.h                       │   ├── hellocm_msgs                    │   │   └── package.xml                  
 ├── src_cmrosif                      │   │   ├── msg                         │   └── hellocm_msgs                     
 │   ├── CMRosIF.patch                │   │   │   ├── CM2Ext.msg              │       ├── msg                          
 │   ├── Makefile                     │   │   │   └── Ext2CM.msg              │       │   ├── CM2Ext.msg               
 │   ├── patch.sh                     │   │   ├── srv                         │       │   └── Ext2CM.msg               
 │   └── User.c                       │   │   │   └── Init.srv                │       ├── srv                          
 ├── build.sh                         │   │   ├── CMakeLists.txt              │       │   └── Init.srv                 
 ├── CMStart.sh                       │   │   └── package.xml                 │       ├── CMakeLists.txt               
 └── ros_setup.bash                   │   └── CMakeLists.txt                  │       └── package.xml                  
                                      ├── build4eclipse.sh                    └── build.sh                             
                                      └── build.sh                                                                     

Figure 8: CM project folder overview with provided ROS and ROS 2 workspace examples 

 

Description of most relevant folders/files: 

 bin/ 

 Location of the CarMaker executable after installing (make install) 

 Data/Config/CMRosIFParameters 

 CarMaker Infofile with parameters for the CMRosIF and CarMaker ROS Node 

 Enable/disable interface/clock server 

 CarMaker ROS Node remapping arguments, 

 i.e. Cfg.Args = __ns:=MyNamespace to push down all topics, ... 

 Accessible via "CM Main GUI -> Extras -> CMRosIF -> Edit Parameters" 
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 More Information see “4.3 Infofile Parameterization” 

 doc/ 

 Documentation for additional modules, like the CMRosIF and CMJobScheduler 

 GUI/ 

 Folder for CarMaker GUI extension of current CarMaker project directory 

 The mod files can be copied to the CarMaker installation folder to be available globally 

 CMExt-CMRosIF.mod: see chapter “4.2 CarMaker GUI Extension” 

 include/ 

 Folder with additional include files 

 The headers cmcppif.h and cmcppifloader.h for CarMaker C++ Interfaces are located in 

this folder 

 lib/ 

 Additionally linked libraries of the CarMaker executable like the CarMaker C++ Interface 

Loader library libcmcppifloader-linux64.so 

 src/ 

 CarMaker source folder for building the CarMaker executable 

 Needs to be updated once using the files located under src_cmrosif/ 

 Makefile 

 Default CarMaker Makefile with additional flags/libraries for using the CarMaker C++ 

Interface Loader module and additional goals to build the ROS workspaces 

 Building CarMaker executable with CarMaker C++ Interface Loader and ROS 

workspaces 

 User.c 

 Loading and triggering CarMaker C++ Interfaces, such as the CMRosIF, using the 

CMCppIFLoader lib/libcmcppifloader-linux64.so 

 see include/cmcppifloader.h for more details 

 src_cmrosif/ 

 patch file and script (CMRosIF.patch, patch.sh) to update the CarMaker source folder 

automatically 

 template files (Makefile, User.c) to update the CarMaker source folder manually 

 build.sh 

 Builds CarMaker and the ROS workspaces. Experimental for fast ramp up of the examples! 

 Using the Makefile <CMProjDir>/src/Makefile of your projects source folder is preferred 

 CMStart.sh 

 Sources your ROS workspace and starts the CarMaker GUI with the GUI extension. File is 

created during the first run of build.sh or make within the CarMaker source directory. 

 ros_setup.bash 

 helper script for sourcing the appropriate ROS workspace 

 used by CMRosIF GUI extension and CMStart.sh script 

 ros/ros1_ws/ and ros/ros2_ws/ 
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 Native ROS workspaces (ROS: catkin, ROS 2: ament) with user packages (messages, 

nodes, …) 

 Including topics and services as well as the external ROS Node and the CarMaker ROS 

Node shared library for the HelloCM example 

 The workspace might also be set as a symbolic link to an already existing ROS workspace 

or referenced in the CM Makefile 

 src/cmnode_hellocm 

 Source code for the CarMaker ROS Node shared library 

 Derives from CarMaker ROS Interface base class located under the cmrosutils 

package 

 Created as a CarMaker C++ Interface 

 Place for customer-specific changes 

 src/cmrosutils 

 General utilities when using ROS in combination with CarMaker 

 Includes base class for the general CarMaker ROS Interface 

 CarMaker ROS Interface base class derives from more general CarMaker C++ Interface 

class to ensure compatibility with the CarMaker C++ Interface Loader 

 src/hellocm 

 Source code for the external ROS node of the example (independent of CarMaker) 

 src/hellocm_msgs 

 Message and Service definitions used by the nodes above 

 build.sh or build4eclipse.sh 

 Build scripts for the ROS workspace. While build.sh runs a normal build, 

build4eclipse.sh prepares the ROS .build/ folder for an eclipse project that can be 

imported to eclipse (inside eclipse: “File -> Import -> Existing Projects into Workspace”) 

4.2 CarMaker GUI Extension 

The CarMaker ROS Interface comes with an optional CarMaker GUI extension module. The 

extension provides an extra menu “CM Main GUI -> Extras -> CMRosIF” in the CarMaker Main 

GUI. The menu extension is included in the file CMExt-CMRosIF.mod. This file can be placed inside 

<CMinstDir>/GUI to be globally available or inside the CarMaker project directory and loaded via 

an additional command line argument -ext <filename>.mod when starting the CarMaker GUI, e.g. 

if the mod file is located in the folder <CMProjDir>/GUI the command could be 

    CM . –ext GUI/CMRosIF.mod    or    CM-9.1.1 . –ext GUI/CMRosIF.mod . 

For the CMRosIF example, the command line is located inside the run.sh script. It is required to 

add the CarMaker installation path to the systems search path (please check chapter “Fehler! 

Verweisquelle konnte nicht gefunden werden. Fehler! Verweisquelle konnte nicht gefunden 

werden.” for additional information) to use it. 
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Figure 9: CarMaker GUI Extension 

 

Following commands are currently available: 

Launch 

This command starts a new terminal, sources the script <CMProjDir>/ros_setup.bash and 

executes ROS Launch. If the feature TerminalCmd is enabled, previously started terminals by the 

Launch feature will be stopped first. The arguments for ROS Launch can be parameterized in the 

Infofile <CMProjDir>/Data/Config/CMRosIFParameters. (see chapter “4.3 Infofile 

Parameterization”) 

Launch & Start Application 

This command works like the command “Launch” described above, but additionally the CarMaker 

executable is started. An already running executable will be stopped. This allows a complete 

start/restart of the simulation setup. Several parameters influence the startup (e.g. Cfg.Features). 

Please check the chapter “Infofile Parameterization” for more information. Please ensure that the 

correct CarMaker executable is selected (“CM Main GUI -> Application -> Configuration/Status”) 

<Restart/Stop> ROS Core/Daemon 

“Restart” stops the currently running roscore and starts again. “Stop” just stops the process. 

Normally not necessary when using the command “Run launch file” where the roscore is 

automatically started with the other ROS nodes. 

Start rqt 

This command starts a new terminal, sources the script <CMProjDir>/ros_setup.bash and 

executes the ROS program rqt. The arguments for rqt can be parameterized in the Infofile 

<CMProjDir>/Data/Config/CMRosIFParameters. (see chapter “4.3 Infofile Parameterization”) 
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List <Basic/Nodes/Topics/Services> 

These commands run the corresponding ROS programs rostopic, rosnode, rosservice and prints 

the output to the CarMaker ScriptControl window. 

Edit Parameters 

This command opens the Infofile <CMProjDir>/Data/Config/CMRosIFParameters for editing. (see 

chapter “4.3 Infofile Parameterization”). 

If nothing happens it is possible that the default editor is not set correctly. For Ubuntu and before 

CM6.0.4 there is an additional mod file CMExt-GUI_PatchUbuntu.mod that fixes this issue starting 

gedit. If you prefer to use another editor, the Tcl variable $Pgm(TextEditor.linux) can be 

manipulated e.g. via ScriptControl (current session only) or by adding an entry with the same 

command to a .CarMaker.tcl-file located in the root directory of the CarMaker project directory or 

your home directory: 

set ::Pgm(TextEditor.linux) gedit 
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4.3 Infofile Parameterization 

Following paramaters can be used to parameterize the CarMaker ROS Interface. The parameters 

allow for a modification of the internal mechanism and e.g. the arguments provided to the CarMaker 

ROS Node in the initialization function CMCppIFLoader_init(). 

The parameters are managed in different groups with their own prefix 

 Cfg.* : General configuration of CMRosIF 

 Launch.* : Parameters related to the command “CM Main GUI->Extras->Run launch file” 

 rqt.* : Parameters related to the command “CM Main GUI->Extras->Start rqt” 

 Node.* : Parameters used inside CarMaker ROS Node. Depends on node design! 

4.3.1 General Configuration 

Cfg.Lib.Path 

This parameter is not optional! 

Path to the CarMaker ROS Node shared library. The path can be absolute or relative to current 

CarMaker project directory or available within the PATH variable, e.g. LD_LIBRARY_PATH. The shared 

library is currently loaded at startup of the CarMaker executable. 

Example: Cfg.Lib.Path = libcmnode_hellocm.so 

Cfg.Mode 

This parameter is optional! Default = 1 

The CarMaker C++ Interfaces can be disabled (Cfg.Mode = 0). In this case the interfaces shared 

library is not loaded after starting the CarMaker executable and the CarMaker ROS Node will thus 

not be available. User functions obtained with CMCppIFLoader_getSymbol() will be NULL pointers 

and will have to be managed by the user (e.g. if (MyFunc != NULL) MyFunc();)! 

Cfg.Name 

This parameter is optional! Default = “cm_node” 

Changes the name of the CarMaker ROS Node provided to the CMRosIF GUI. To dynamically 

change the actual name of the node, use remapping arguments that can be set using the Cfg.Args 

infofile parameter. 
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Cfg.Args 

This parameter is optional! Default = “” 

The parameter string is mapped to the argc and argv arguments and eventually evaluated by the 

ROS init functions. This allows the user to provide arguments in a style of a ROS standalone node 

where the arguments argc and argv are provided by the main() function (e.g. for remapping 

arguments, …). 

Remapping arguments can’t be provided directly as arguments to the CarMaker executable! 

Example with Cfg.Args = __ns:=/carmaker : 

CarMakerRosInterface::init() will provide argc=2 and argv[1]=“__ns:=/carmaker” to the 

ROS init function: Node name, Topics, etc. will be pushed down to the ROS namespace /MyVhcl 

(so the node name /cm_node will become /carmaker/cm_ode). 

Cfg.Features 

This parameter is optional! Default = “TerminalCmd” 

The parameter allows a space separated list with different special features available for the 

CMRosIF. 

 AutoStart (experimental) 

 Enables an automated mechanism when CarMaker TestRun is started 

 Stopping ros launch and CM executable 

 Start of ros launch file and CM executable 

 calls Cfg.LaunchProc in context startsim 

 TerminalCmd (experimental, Ubuntu only) 

 Mechanism to handle multiple Terminals 

 Automatic termination of launch terminal 

 Optional multi terminal/tab mechanism 

 Managing different tabs and terminals and running multiple launch files in the same (one 

tab for each) or multiple terminals 

 Create additional terminals with Linux commands 

 Check Cfg.UserUtils.FPath and Cfg.LaunchProc 

 Additional parameterization via keys 

 <pre> = Cfg.TerminalCmd 

 <pre>.startwait = Time to wait in ms after start command was executed 

 <pre>.stopwait = Time to wait in ms after terminal stop request 

4.3.2 Launchfile and Rqt 

Launch.Args 

Arguments provided to the ROS program roslaunch/ros2 launch when the GUI command 

“CM Main GUI->Extras->CMRosIF->Run launch file” is used. 
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Example: 

Launch.Args = hellocm hellocm.launch use_sim_time:="true" will run the launch file 

hellocm.launch from ROS package hellocm providing the argument use_sim_time:="true". 

rqt.Args 

Arguments provided to the ROS program rqt when the GUI command “CM Main GUI->Extras-

>CMRosIF->Start rqt” is used. 

4.3.3 CMNode Internal and Clock Server 

Node.Mode 

Usage depends on node design! See source files of CarMaker ROS Node for more information. 

The intention of this parameter is to set an node internal mode. 

    e.g. 0=Off, 1=Enabled, 2=ThreadedSpin, … . 

Node.Sync.Mode 

Usage depends on node design! See source files of CarMaker ROS Node for more information. 

The synchronization mechanism is currently under investigation. Currently external ROS nodes can 

be synchronized only via the /clock Topic published by the CarMaker ROS Node. But CarMaker 

does not wait for the answer, so incoming Topics may arrive delayed and not in an deterministic 

way. 

The intention of this parameter is to set a node internal synchronization mode. 

    e.g. 0=NoSync, 1=SyncViaTopics, … . 

Node.Sync.TimeMax 

Usage depends on node design! See source files of CarMaker ROS Node for more information. 

Defines the timeout in seconds if synchronization is enabled. By default CarMaker will throw an 

error and stop the current TestRun if the expected topic is not received within this timeout. 

Node.UseSimTime 

Usage depends on node design! See source files of CarMaker ROS Node for more information. 

If this parameter is set to 1 CarMaker will act as a ROS Clock Server by setting the ROS parameter 

/use_sim_time and publishing the current simulation time to /clock every Node.nCyclesClock 

cycles. 

Node.nCyclesClock 

Usage depends on node design! See source files of CarMaker ROS Node for more information. 

Number of CarMaker cycles. Generally duration for 1 cycle is 1ms. 
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4.4 Build Process 

Chapter “2.3 Build the Example” shows how to build the example using the CarMaker Makefile. All 

included steps can be executed by hand as described below. 

4.4.1 ROS Workspace 

The ROS workspace (e.g. <CMProjDir>/ros/ros1_ws, native ROS workspace) contains the script 

build.sh, that makes some preparation (e.g. sourcing setup.bash from ROS installation) and 

executes the default ROS command catkin_make (ROS default) or colcon build (ROS 2 default). 

All packages located in src folder below the workspace will be built. To ignore a package, add an 

empty file called CATKIN_IGNORE (ROS) or AMENT_IGNORE (ROS 2) to the root level of a package 

(e.g src/hellocm/CATKIN_IGNORE). 

The location of the ROS workspace inside a CarMaker Project Directory is optional. The ROS 

workspace can also be in a different place and linked via symbolic link. Without a link inside 

<CMProjDir>/ros/ some features shown with the provided example might not work. 

For detailed information check http://wiki.ros.org/catkin/workspaces. 

For the provided example all code with ROS dependency is located in this workspace (e.g. external 

ROS Node and the CarMaker ROS Node shared library, …). 

4.4.2 CarMaker ROS Node Shared Library 

The CarMaker ROS Node shared library is built within the ROS workspace in its own ROS package 

(e.g. <CMProjDir>/ros/ros1_ws/cmnode_hellocm). 

 The path to the CarMaker ROS Node shared library which is dynamically loaded inside the 

CarMaker executable can be adapted by editing the parameter Cfg.Lib.Path (see 4.3.1 

General Configuration) 

 The shared library contains the REGISTER_CARMAKER_CPP_IF macro in order to be loadable by 

the interface loader 

 Additional user defined functions can be created inside the library and called from e.g. User.c 

via function pointers (see example code for cmnode_hellocm.cpp, User.c and 

cmcppifloader.h) 

 CarMaker Data (e.g. Sensors and Vehicle Model) can be directly accessed inside the CarMaker 

ROS Node shared library. Just add the necessary headers from <CMInstDir>/include/. 

Please note that the shared library will depend on CarMaker libraries and the CarMaker version 

at compile time! For a new CarMaker Version (especially new major releases) the library needs 

to be recompiled. 

 The CarMaker Version (path and version number) can be adapted in the CMakeLists.txt. 

 

Please check CMakeLists.txt and package.xml inside the cmrosutils and cmnode_hellocm 

packages for more information. 

http://wiki.ros.org/catkin/workspaces
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4.4.3 CarMaker Executable with CarMaker C++ Interface Loader 

The CarMaker executable with the CarMaker C++ Interface Loader is built using the CarMaker 

Makefile, e.g. located in <CMProjDir>/src. To build it open a new terminal and execute make 

install inside this folder (more information see “Programmers Guide”). The CarMaker executable 

for this example usually only needs to be compiled after modifications in the CarMaker user 

modules (User.c, …) or when the CarMaker C++ Interface API changes. 

The CarMaker C++ Interface Loader currently consists of a header i.e. 

<CMProjDir>/include/cmcppifloader.h and a shared library i.e. 

<CMProjDir>/lib/libcmcppifloader-linux64.so. The shared library is linked with the CarMaker 

executable and is automatically loaded at startup. 

4.5 Interaction of CarMaker and the CarMaker ROS Node 

Shared Library 

The CarMaker ROS Node shared library is not directly linked to the CarMaker executable. When 

calling the loading function of the CarMaker C++ Interface Loader inside User.c the CarMaker 

ROS Node shared library parameterized by Cfg.Lib.Path (see 4.3 Infofile Parameterization) will 

be loaded during runtime of the CarMaker executable. Commonly used default hook points already 

exist (see cmcppifloader.h and cmcppif.h). These hook functions call the appropriate member 

functions of the CarMaker ROS Node shared library. 

For example, CMCppIFLoader_testrunStartAtBegin() will eventually call the the member function 

CMNodeHelloCM::userTestrunStartAtBegin(). 

The CMCppIFLoader_load() with the appropriate interface name (“CMRosIF”) has to be called 

before any other function from the CMCppIFLoader API. 

Additional user functions may be defined as extern “C” inside the CarMaker ROS Node shared 

library. The function CMCppIFLoader_getSymbol() allows to search for functions/symbols inside 

the recently loaded CarMaker C++ Interface library and returns a function pointer that can be used 

e.g. in User.c. Check User.c and the shared library source code for an example. 

Variables from the CarMaker environment can be directly accessed by including the relevant 

CarMaker headers (e.g. Vehicle.h for vehicle velocity, …) from the CarMaker installation directory 

(e.g. /opt/ipg/carmaker/linux64/include) in the CarMaker ROS Node shared library. Libraries 

for linking are located in the lib/ folder of the CarMaker installation directory. 
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4.6 CarMaker Job Scheduler  

The job scheduler is used to execute one or more cyclic tasks (e.g. publish and subscribe 

messages, copy data from message buffer to vehicle model, …) dependent on e.g. the CarMaker 

cycle number relative to simulation start. This allows to publish data e.g. every 10ms with an offset 

of e.g. 5ms. 

For an example on how to set up a publisher and subscriber, please have a look at: 

 cmrosutils/cmjob_publisher.h[pp], 

 cmrosutils/cmjob_subscriber.h[pp], 

 cmnode_hellocm.h[pp] and 

 cmnode_hellocm.cpp. 

For more details, please refer to the Doxygen documentation available at 

<CMProjDir>/doc/CMJobScheduler.html. 
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4.7 Process Synchronization 

By default ROS is a non-deterministic software framework that transfers messages between 

several nodes using the publish/subscribe mechanism. The actual time until a message is received 

depends on system workload and the transmission path. Running multiple processes independently 

may result in non-reproducible simulations. If running the simulation in soft real time the effect might 

be small and therefore acceptable for many use cases, but running CarMaker with maximum 

simulation speed small deviations in the message timing will have an impact on simulation results. 

Therefore a simple example of a topic based synchronization between an external ROS Node and 

the CarMaker ROS Node is available that forces CarMaker to wait until the anticipated message is 

received. The synchronization is based on knowledge about the expected cycle time of the external 

node and uses an internal cycle counter inside the CarMaker Node. 

The mechanism may be used in different ways 

1. Simulation time based synchronization 

 The ROS /use_sim_time mechanism needs to be activated 

 CarMaker ROS Node has to act as a clock server 

 ROS Timer inside external ROS Node that reacts on changes in simulation time 

 Provide cycle time and topic name for synchronization to CarMaker ROS Node 

2. Data triggered synchronization 

 ROS Node interaction with one or more calculation chains, each chain finishes with a topic 

in the CarMaker ROS Node that is used for synchronization 

 One ore more subscription(s) in external ROS Node(s) 

 Includes algorithm, etc. 

 ROS publish at the end of calculation chain 

 Provide cycle time and topic name for synchronization to CarMaker ROS Node 

 CarMaker ROS Node waits in specific cycle until all messages have arrived 

 

The simulation time based synchronization is implemented in the example described in chapter 

“HelloCM”. The effect of synchronization is demonstrated in the chapter “Topic Based 

Synchronization”. 
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5 Release History 

5.1 Version 1.0.0 

General 

 Renamed CarMaker ROS Interface loading library to CarMaker C++ Interface Loader 

 Defined CarMaker C++ Interface as abstract class 

 CarMaker ROS Interface inherits from CarMaker C++ Interface 

 Implements general ROS functionality 

 User example CMNodeHelloCM inherits from CarMaker ROS Interface 

 Implements user-specific functionality 

 Replaced job mechanism with CMJobScheduler 

 Refactored ROS workspaces 

 Tested with ROS 2 Foxy Fitzroy and Galactic Geochelone 

5.2 Version 0.7.0 

General 

 CMRosIF including the GUI distinguish between ROS and ROS 2 depending on which version 

is sourced at startup  

 Integrated native ROS 2 workspace with HelloCM example 

 tested with Eloquent Elusor and Dashing Diademata 

 Simplified installation and build process that supersedes the need of changing CM versions in 

multiple places 

 Fixed a deprecation warning by gnome-terminal in TerminalCmd 

5.3 Version 0.6.8 

General 

 Update User.c and Makefile for CarMaker executable in <CMProjDir>/src/ 

 Default target for ROS build and examples is devel (before install) 

 Add script <CMProjDir>/ros/ros1_ws/src/build4eclipse.sh 

 Builds a catkin workspace with eclipse project files inside the build folder and allows a 

direct import as eclipse project 

 According to “Catkin-y approach” described on http://wiki.ros.org/IDEs#Eclipse 

 The script can be called manually on demand 

 Now the demo package is independent from CarMaker version and can be easily integrated into 

an already existing CarMaker Project Directory 

http://wiki.ros.org/IDEs#Eclipse
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Version 0.6.8 

Examples: HelloCM 

 New example for topic based synchronization 

 New job mechanism für cyclic data publishing on CMNode Side 

 Renamed ROS messages and restructured global variables for CMNode and external ROS 

Node 

GUI 

 New menu entry Launch & Start Application 

 New experimental feature TerminalCmd 

 Manages terminals started via CarMaker GUI e.g. menu entry “CM Main GUI -> Extras 

-> CMRosIF-> Launch” 

 More information see chapter “Infofile Parameterization” and parameter Cfg.Features 


